Preview not compatible with new Mac OS Maverick
issueid=643 10-30-2013 07:48 PM
Junior Member
Preview not compatible with new Mac OS Maverick

Hi,
When i updated my system to new Maverick and run the preview, when i open it, it seems ok, but after loading prv files or importing Abaqus inp files, the display area just stuck did not show any geometry, doesnot respond to mouse control. Just stopped as before loading any files. and other parts like the menus and model trees seem to be normal. right click is still working in the display area, but changing view to top or left doesnot make any view changes.

regards
Zhang Liang
Issue Details
Issue Number 643
Project PreView
Category Unknown
Status Unconfirmed
Priority Unknown
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 2
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




03-24-2014 04:09 PM
Junior Member
I have the same problem in OSX 10.7.5.

Open an existing .prv, all the information is there (material properties, geometry, BCs) but the model viewing window is empty and the grid is frozen.

Stephen Ferguson

(p.s. very nice talks on FEBio at the ORS this year!)

03-24-2014 08:12 PM
Junior Member
Hi, Stephen
My problem was solved after a month when i updated my JAVA.Hope this can help you.

regards
Zhang Liang




Quote Originally Posted by sj_ferguson
I have the same problem in OSX 10.7.5.

Open an existing .prv, all the information is there (material properties, geometry, BCs) but the model viewing window is empty and the grid is frozen.

Stephen Ferguson

(p.s. very nice talks on FEBio at the ORS this year!)

03-25-2014 01:15 AM
Junior Member
Thank you for the tip, but unfortunately an upgrade of Java didn't solve it. I suppose I could try (finally) moving to Maverick.

Best regards,
Stephen Ferguson

03-25-2014 07:56 AM
Moderator
Steve - Thanks for your kind comments about the ORS FEBio talks!

I'll point Gerard Ateshian and Dave Rawlins to this thread, they are our resident Mac experts.

Jeff

03-25-2014 12:06 PM
Developer
Stephen,

The code is compiled for OSX 10.7 and upward, but unfortunately we don't have an os older than 10.8 to test it on. I'm trying to hunt one down. In the meantime let me know if you upgrade to a newer OSX and have the same problem.

Best,

Dave

03-25-2014 12:36 PM
Junior Member
Hi Dave,

Thanks for checking. I upgraded to OSX 10.9.2 and unfortunately still have the same problem.

Regards,
Stephen

03-25-2014 12:42 PM
Developer
Is the problem specific to one .prv file? Are you able to open other files? If so, can you attach the .prv file?

Dave

03-25-2014 12:58 PM
Junior Member
It's not a specific .prv. I tried first with some trial examples from the biphasic tutorials and a few other example files. Even if I just create a box, save the .prv, exit, re-open the box.prv, the graphics screen freezes (same as with any .pdv). I will try it on my wife's Mac tonight to see if it's only mine.

03-25-2014 02:30 PM
Junior Member
Apologies for the goose chase. It works fine on the other MacBook. I'll have to figure out why it's a problem on mine, but the code is certainly fine.

Regards,
Stephen

10-21-2014 02:21 AM
Junior Member
Hi there,
The same thing is now happening with Mac OS X Yosemite (10.10) with the import of a STL file (any) into preview. The grid is just frozen and the model does not display.
Michael

10-22-2014 10:15 AM
Developer
Hi Michael,

I'll see if I can find a Mac with Yosemite to test it. We've noticed some problems with certain graphics cards on the Mac. If you have access to a Mac with a different graphics card, please try it there and let us know if it works.

Thanks,

Dave

10-22-2014 10:31 AM
Developer
Michael,

We just uploaded a new version of PreView. Please try it and see if you have the same problem.

Thanks,

Dave

+ Reply